Getting started

Download Foxglove Studio for your operating system – whether that's Linux, Windows, or macOS.

When you first load the app, you will see an introductory dialog, with "Open data source" options and "Help" resources. On subsequent app loads, you will also be able to reconnect to your most recently selected data sources in the "Recents" list.

Open dialog

If you want to get a sense of what you can visualize in Foxglove Studio before connecting to your own data, click on "Explore sample data" to load a sample dataset adapted from nuScenes in an example layout for playback. Hover over each panel to see its name and toolbar, and seek to different places on the playback bar to see the panels update with new information.

Sample nuScenes data

The app's sidebar contains the following tabs:

  • Data sources – Select a data source to connect to
  • Layouts – Save different Studio layouts for later use
  • Add panel – Add a panel of your choice to your current layout
  • Panel settings - Edit a selected panel's settings
  • Variables - Set app-level variables for use throughout your current layout
  • Account - Sign in to access collaboration features like shared layouts (coming soon)
  • Preferences – Configure app settings, privacy preferences, and experimental features

Toolbar menus

You can use the application toolbar menus to do the following:

  • Open a new Studio window (File > New Window)
  • Connect to a data source (File > Open ROS 1, Open ROS 1 Rosbridge, etc.
  • Reset your layout to the Welcome layout (Help > Welcome)
  • Read documentation on message path syntax (Help > Message path syntax)
  • Reference keyboard shortcuts (Help > Keyboard shortcuts)
  • Open the Foxglove website (Help > Learn more)